Twitch is doing it again

RESOLVED

This incident has been resolved.

Posted 14 days ago. 12:04 AM on April 3, 2024

IDENTIFIED

We’ve disabled Twitch integration for the time being. If only they would actually reply to us…

Posted 14 days ago. 11:11 PM on April 2, 2024

This incident affects: Caffeinated