Theta.tv logins not working.

Resolved after 3 days 15 hours 41 minutes

Theta has implemented a fix, logins should be working now.

Posted 3 years ago

Identified

The issue has been identified and a fix is being implemented.

Posted 3 years ago

Investigating

We've identified an issue with Theta.tv logins and are awaiting a fix from their dev team.

Posted 3 years ago