Twitch is doing it again.

Resolved after 1 hour 8 minutes

This incident has been resolved.

Posted 2 years ago

Identified

All we can do is wait it out :(

Posted 2 years ago

Component impacted: Caffeinated