RESOLVED
Looks like our reverse-proxy was the culprit. We've juiced it to hopefully avoid this issue in the future :)
Posted 8 months ago.
MONITORING
A fix has been implemented and we are monitoring the results.
Posted 8 months ago.
INVESTIGATING
We are currently investigating this issue.
Posted 8 months ago.
Component impacted: Caffeinated