Twitch logins are taking a long time to complete.

RESOLVED

This incident has been resolved.

Posted 11 months ago.

IDENTIFIED

Twitch is doing us in. Nothing I can do about it for now.

Posted 11 months ago.

Component impacted: Caffeinated